Page 1 of 1

BUG? New user approval process...

PostPosted: Mon Feb 10, 2014 10:08 am
by sulfur
I'm using 1.7.4 (just updated this am :) ) and we had one of our players create a new user, one that was a duplicate account, so I deleted it this morning rather than approving it (after sending them their correct login information/etc). When I checked the tables, the entry was removed from the "people" table, but there was still a user in the "user" table.

Is that intentional?

Re: BUG? New user approval process...

PostPosted: Mon Feb 10, 2014 12:30 pm
by GregS
No, the user record should be removed too. I'll look into it, should be an easy fix.

Re: BUG? New user approval process...

PostPosted: Mon Feb 10, 2014 2:42 pm
by GregS
Fixed. It was working in the case of third-party user databases, but not for the Zuluru stand-alone case. Thanks for catching this!

Re: BUG? New user approval process...

PostPosted: Mon Feb 10, 2014 2:44 pm
by GregS
Also, for the record, in such cases I typically use the "merge backwards" option, which will keep the user's new user name, password, contact info, etc., but "move" it all to their pre-existing account, so that their old id number, waivers, registrations, team affiliations, etc. are all preserved.

Re: BUG? New user approval process...

PostPosted: Mon Feb 10, 2014 3:24 pm
by sulfur
In this case, they'd forgotten their password, so created an entirely new account rather than using the "forgot password" option.

Silly people. :)

Re: BUG? New user approval process...

PostPosted: Mon Feb 10, 2014 3:29 pm
by GregS
Users: can't live with them, can't live without them...